Samsungs populära och kritikerrosade 840 Evo erbjuder bra prestanda och bra lagringskapacitet till ett mycket bra pris. Men efter rapporter med underliga prestandaproblem från många 840 Evo ägare har vi tagit en närmare titt på fenomenet och hittat tillfälliga lösningar i väntan på mer information från Samsung.

UPPDATERING 2014-09-24 17:00 – Vi har fått ett officiellt uttalande från Samsung Sverige som lyder följande:
“Vi är medvetna om den senaste tidens problematik som uppdagats kring SSD-disken 840 EVO. Samsung beklagar eventuella besvär som våra användare upplevt. Den tillfälliga prestandaförsämring som uppstår vid åtkomst av vissa filer kommer att åtgärdas med hjälp av ny firmware. Uppdateringen kommer att finnas tillgänglig via Samsung webbsida under oktober (preliminärt datum 15 oktober).

I ungefär ett år så var Samsungs 840 Evo den överlägset mest sålda SSD-enheten på den svenska marknaden. Vi på NordicHardware var med när enheten lanserades och efter vårt test så hade vi svårt att hitta några större brister på enheten. Likt många andra medier gav vi enheten en varm rekommendation då 840 Evo visade sig vara en oslagbar kombination av låg strömförbrukning, duglig prestanda, kapacitet och pris. De senaste veckorna så har det nu börjat dyka upp rapporter om att allting inte är som det ska med en av Samsungs mest populära SSD-enheter någonsin.

Långvarig användning som är närmast omöjlig att utvärdera

Många som precis köpt en SSD tycker att det är lite spännande att köra ett prestandatest eller två. Delvis för att se hur stor skillnad det är mot den där gamla tröga hårddisken som man just bytt ut. Men delvis också för att se att den nya SSD-enheten presterar så bra som den ska. Efter det så börjar man installera upp sina program och man känner sig trygg i att enheten presterar som den ska. Skrivprestandan blir ofta lite sämre med tiden och det får man räkna med, läsprestandan är däremot mer eller mindre konstant oavsett hur mycket data man har eller hur gammal enheten är.

För några veckor sedan så började några användare upptäcka att prestandan vid läsning på deras 840 Evo-enheter inte riktigt stämde. Vissa filer på enheten gick märkligt nog väldigt mycket långsammare att flytta än vad de gjort tidigare. Det gällde dock inte alla filer, utan endast vissa. Det verkade primärt vara filer som legat länge utan att ha ändrats eller flyttats. Typiska exempel är datafiler för spel (som varit installerade länge) eller filer som tillhör operativsystemet. Man provade då att köra diverse olika testprogram och de allra flesta visade inte några problem alls. Enheten spottar där glatt ur sig 400 megabyte per sekund precis som den ska. Detta beror på att många testprogram (som exempelvis Atto, Crystaldiskmark osv) genererar upp en ny fil på disken och mäta prestandan med densamma. Eftersom testfilen alltid är nyligen skapad så presterar enheten som den ska. Tar man istället ett testprogram som provar att läsa den befintliga datan på disken så upptäckte man att på vissa delar av LBA (Logical Block Adressing – Ett sätt att kartlägga vart data lagras fysiskt på enheten) så är prestandan som den ska men att den samtidigt på andra delar är betydligt lägre. I vissa fall så är prestandan en bra bit under gamla hårddisknivåer på mellan 20 och 50 megabyte per sekund.

Mindre troligt att det handlar om drivrutiner eller testmjukvara

Detta skulle ha kunna vara en bugg i en drivrutin eller något testprogram, men ju mer man tittar på resultaten desto mindre trolig blir den teorin. För det första så har flera användare sagt att en Secure Erase löser problemet tillfälligt, men det verkar komma tillbaka efter ett tag. Felet uppstår inte heller på några andra enheter förutom Samsungs TLC-baserade enheter 840 och 840 Evo (gäller även mSATA versionen av 840 Evo). Exempelvis så har inte 840 Pro samma problem. Felet verkar även uppstå under Linux och vissa har även nämnt att de haft problem i Mac OS X.

Bekräftade enheter med problem Samsung 840, Samsung 840 Evo (både SATA och mSATA)
Ej påverkade Samsung 840 Pro

Bara problem med gamla filer

Detta är alltså någonting som ser ut att dyka upp med tiden för de som använt sina enheter kontinuerligt under längre perioder, ofta sex månader eller längre. Problemet ser också ut att bli värre med tiden vartefter fler filer blir äldre och ligger kvar på samma plats. Nya filer verkar samtidigt alltid fungera precis som de ska. Detta problem var något som vi på Nordichardware var tvungna att gräva lite djupare i. Tyvärr så finns väldigt lite bekräftad information om vad felet beror på eller vilka som påverkas av det. Våra försök att framkalla felet på vårt eget testexemplar har tyvärr varit lönlösa då vi inte har något testsystem som kör 840 Evo kontinuerligt, med andra ord har vår enhet inga äldre filer lagrade i sina minnesceller. Våra försök att påtvinga enheten äldre filer har inte heller framkallat felet. Det närmaste vi initiallt kom var att en av våra redaktionsmedlemmar lyckades bekräfta att han har samma fel på sin privata 840 Evo-enhet (alltså inte ett testexemplar från Samsung).

Samsung är medvetna om problemen men ger inga svar

Vi har givetvis varit i kontakt med Samsung för att försöka få fram ytterligare information, men tyvärr så vet de inte så mycket i dagsläget. Vi har fått veta att Samsung uppmärksammat problemet och att de har börjat titta närmare på det. Samsung vill dock inte kommentera huruvida det är ett problem som går att lösa eller om det är något som man kommer att få leva med. Det verkar i alla fall som att mer eller mindre alla Samsung 840 Evo och Samsung 840 som varit i drift i mellan ett halvår och ett år, är påverkade.

Våra egna tester

På fredagskvällen så lyckades vi dock få tag i en långtidsanvänd SSD som mycket riktigt visade sig påverkad av felet som många användare rapporterat om. Vi körde lästestet i HDTune på denna enhet och på vårt eget exemplar (som installerades i veckan). Vi passade även på att köra testet på en av våra arbetsstationer som installerades för ungefär 2 år sedan. Denna maskin kör en Intel 510 250GB enhet. Skillnaderna ser ni nedan.

Teorierna om vad som orsakar prestandaproblemen är många. Det ser uppenbarligen ut som om att gamla filer inte kan läsas lika fort. Detta borde peka mer mot ett fel i Windows eller en drivrutin. Anledningen till det är att SSD-enheten egentligen inte har en aning om vilka databitar som tillhör vilken fil, ännu mindre hur gamla de är. Det är ett jobb för filsystemet. Samtidigt så är inte felet exklusivt för Windows och därför borde filsystem, operativsystem och drivrutiner inte heller vara en faktor. För att bekräfta detta så gjorde vi en “sector to sector clone” av den 840 Evo som har problemet, till vår egen 840 Evo 250GB. Så om problemet ligger i operativsystemet, drivrutiner eller liknande, då borde felet dyka upp även på vår enhet efter detta. Samma sak borde hända ifall enheten på något sätt känner av vilka filer som är gamla. Då borde vår kloning kopiera felet till vår 840 Evo och vi borde få samma resultat på båda enheterna. Så direkt efter kloningen så körde vi samma test igen på vår 840 Evo.

Inga problem med gamla filer klonade till nya enheter

Resultatet visade precis samma siffror som vi hade på vår 840 Evo innan kloningen. En stadig läsprestanda på ganska exakt 400 megabyte per sekund. Detta skulle i så fall tyda på felet ligger direkt i enhetens firmware eller hårdvara. Vi gissar att felet ligger i enhetens tabell som kopplar LBA till fysiska minnesplatser. När operativsystemet försöker läsa in en fil så säger den åt LBA vilka block med data som behöver läsas från enheten. När detta når SSD-enheten så måste detta översättas till vilken fysisk plats i minnet som just dessa data ligger lagrad på. Denna översättning sker med en stor tabell som håller reda på var data finns. Tabellen cachelagras sedan i enhetens DRAM för snabb åtkomst. Om något här är fel så skulle det kunna förklara problemet. Vartefter mer data skrivs till enheten så blir tabellen mer och mer komplex och detta skulle kunna vara en bidragande orsak till problemet.

Vad kan man göra om man är drabbad?

Vi gjorde ytterligare tester på vår felaktiga enhet för att se vad man kan göra om man är drabbad. Vi lämnade enheten i vila under 10 timmar för att se om enhetens städrutiner skulle åtgärda felet. Men resultaten var precis demsamma. Inte heller att radera bort stora filer och frigöra mer utrymme (trigga TRIM på de LBA som dessa filer tog upp) gjorde någon skillnad. Inte heller genom att bort gamla filer (de som presterar dåligt) lyckades vi förbättra situationen. Som en sista åtgärd så raderade vi filsystemet och testade igen, även då kvarstod problemet. Men efter att vi gjorde en formatering av hela disken (TRIM på hela enheten) så återställdes prestandan fullt ut. Efter att vi återställt filsystemet från en diskavbildning som vi gjorde tidigare, så ser vi att felet nu är “löst”.

Tillfälliga lösningar på problemet

Det går alltså att lösa problemet genom att ta en kopia på hela enhetens innehåll, formatera enheten och sedan lägga tillbaka allting igen. Tyvärr så är detta vare sig en enkel eller en permanent lösning. En annan “lösning” verkar tillsynes vara att defragmentera enheten. Detta är däremot ingenting som vi rekomenderar att man gör då det sliter onödigt mycket på enhetens minnesceller och sänker livslängden. Men i det här fallet så innebär det att en del data skrivs om till en ny plats i LBA, vilket gör filen “ny” och prestandan förbättras. Med största sannolikhet så kommer även problemet tillbaka och det kommer troligtvis fortsätta vara så tills det att Samsung släpper en uppdaterad firmware eller presenterar någon annan fungerande lösning. Vi kommer givetvis att hålla er uppdaterade om problemet vartefter vi får mer information från Samsung.

Testa gärna om du har problem med din 840 Evo genom att själv kör HDTune på din enhet och dela med er av era resultat i kommentarerna. Era resultat och kommentarer kommer vi att ta upp i diskussioner med Samsung för att komma närmare en lösning på prestandaproblemen med deras populära Samsung 840 Evo-enhet.

Se svenska SSD-guiden för våra SSD-rekommendationer

Som vanligt, titta in i Svenska SSD-Guiden för en jämförelse av alla de senaste SSD-enheterna på marknaden med testresultat, omdömen och utmärkelser.

Skriv en kommentar

29 Kommentarer på "Så kringår du prestandaproblemen i Samsung 840 och 840 Evo"

Notifiera vid
avatar

Sortera efter:   senaste | äldsta | flest röster
Ramunas
Gäst
Ramunas
2 Årtal 5 dagar sedan

here is mine test with hdtune. used ssd is samsung evu 840 120gb.

Patrik A
Gäst
Patrik A
2 Årtal 4 dagar sedan

Gött, har väntat på denna artikeln i 2 veckor.Blir bra med en firmwarefix det är ju enklast men är felet så illa att det inte är gångbart bör enheterna återkallas.

Tills vidare har vi precis fått och börjat uppgradera våra system till Crucial MX100.

Och ett stort tack till Gustav Gager som tog sig tid att sammanställa denna artikeln när igen annan sida verkade villig som jag kontaktade.

Samsung bör dessutom fixa sitt support som är ett rent skämt. Man låter inte oroade kunder som ringer, e-mailar flera gånger via alla samsungs kanaler att bli hängandes utan svar eller med svar som att det inte är fel på deras enheter.
Out soursat support som medger att dom har noll kontakt med samsung är inget annat än en fasad för att ge sken av att man bryr sig. Pratat med ÅF som säger precis samma sak också om deras support.

2 veckor med deras support och enbart stone walled hela tiden så bestämde jag att samsung blir det ej mer om kunde inte är värd ett skvatt när man väl får problem som kunden inte kan rå på.

Sundae
Medlem
2 Årtal 4 dagar sedan

Ajdå, det var inte bra, jag som har rekommenderat 840 Evo till höger och vänster. Förhoppningsvis kommer de ut med en firmwarefix snart.
Så här ser min 840 Evo 1TB ut:

Patrik A
Gäst
Patrik A
2 Årtal 4 dagar sedan

quote name=”Sundae”]Ajdå, det var inte bra, jag som har rekommenderat 840 Evo till höger och vänster. Förhoppningsvis kommer de ut med en firmwarefix snart.
Så här ser min 840 Evo 1TB ut:
[/quote]

2.8MB/sek på 40% av enheten är bland det värre jag sett. Har sett en med 1MB/sek på 25% av enheten.

Tyriama
Gäst
Tyriama
2 Årtal 4 dagar sedan

http://imgur.com/cPAM4eU

840 EVO 250gb som har vært installert i ca. 5 mnd.
Det er den 3de Evo jeg har installert, og den eneste som har fungert i mer enn 2 uker. Men jeg ser jo nå det er ikke riktig det heller…

Patrik A
Gäst
Patrik A
2 Årtal 4 dagar sedan

Min 840 EVO var nere på 50MB/sek och är 5 månader gammal. Tar inte låg tid alls. 840 verkar ta 10-11 månader därimot i alla fall don två jag testat.

Mezzlock
Medlem
2 Årtal 4 dagar sedan

Hm, har inte tänkt särskilt mycket på att jag skulle haft problem med min 250GB EVO, men då har jag 2 andra SSD som används till mycket också.. OS sitter dock på EVOn men spelen har inte varit installerade särskilt länge. Körde testet och lägsta hastighet landade på 23.2MB/s ..

André Aronsson
Medlem
2 Årtal 4 dagar sedan

typiskt… jag hade en installation som nästan var ett år gammal…. men jag formaterade om datorn för att köra en testversion av win8.1… och nu har jag gått tillbaka till 7an igen så jag har inte problemet… av min erfarenhet så tycker jag inte datorn med den första installationen var något nämnvärt seg heller så jag vet inte riktigt om jag var drabbad 😛
(min nuvarande installation ligger dock uppe o snurrar i 370-408MB/s så som det ska)

T
Gäst
T
2 Årtal 4 dagar sedan

Har detta problemet med min 840, installerat den i 2 olika datorer dom senaste 18 mån. Samma skräpresultat i båda två. Jag vill inte ha nån samsung-fusklösning som kommer om 6 år, denna SSD ska förbjudas med lag. Har kontaktat CDON och hänvisat till diverse trådar om detta, får se vad dom säger. Jag kräver pengarna tillbaka eller en motsvarande SSD med MLC. Kommer dom med förslag om Kingston V300 så blir det fullt atomkrig =) Den jäkeln är ju ökänd, men “motsvarande” jo, om man ser på skrivhastigheten 20MB heheeee…

Birks
Medlem
2 Årtal 4 dagar sedan

Blev nyfiken och testade på min 250GB 840 EVO som är OP och Rapid Mode enabled.
Kopiering av en fil från 2013-10-27 på 1,3GB till samma Samsung disk gav ungefär 15mb/sec.
Testade sedan att göra en kopia på den nya filen och fick då över 700mb/sec
Testade sedan att kopiera filen från Samsung disken till en RAID 0 av 4st gamla 80GB Intel G2 SSD diskar och fick då ca 40mb/sec.
Kopiering av filen från Raid 0 till Raid 0 igen gav en bit över 1000mb/sec
Testade sedan att kopiera en 1,1GB fil från 2013-04-26 från Intel Raiden till Samma Raid fick igen en bit över 1000mb/sec
Kopierade sedan filen från Intel Raiden till Samsung EVO disken och fick åter över 1000mb/sec
Så jag kan också bekräfta att problemet bara verkar finnas när man läser gamla filer på Samsung Evo disken.

ergoen
Gäst
ergoen
2 Årtal 4 dagar sedan

Min 840 EVO innan secure erase:
?dl=1
efter secure erase:
?dl=1

Fick inte “hela” prestandan återställd av tömningen dock..

Gojj
Gäst
Gojj
2 Årtal 4 dagar sedan

Ojdå, Testade min 250Gb 840Evo nyss & fick katastrofala siffror.
Hittade sen ett tips om att köra ”DiskFresh”. 56Minuter senare, så visade Hdtune fina siffror igen.
Så det kan jag rekommendera i väntan på en patch.

Swinger
Medlem
2 Årtal 4 dagar sedan

Jag fick inte ett speciellt imponerande resultat på min 250 EVO heller. Ca 30 % av disken presterade på 20-30 MB/sekund.

Men jag är tveksam till vad dessa resultat säger? Min Corsair Force 3 presterar “jämndåligt” på ca 160 MB/sekund read över hela disken. Men i ATTO ligger båda diskarna på acceptabel prestanda (är lite limiterad över att jag kör ett gammalt X58-moderkort med SATA II.

Vad borde min Corsair (som är 90% full) prestera i HD Tune?

MickeLZ
Gäst
MickeLZ
2 Årtal 4 dagar sedan

EVO 250GB.
Installationen är cirka 4 månade gammal.

http://imgur.com/RTzWwbU

gustav II
Medlem
2 Årtal 4 dagar sedan

jag gjorde uppenbarligen ett misstag som snålade och köpte 1TB samsing 840 evo istället för två ocz vector / samsung 840 pro. Vissa saker är för bra för att vara sant..

Tur att jag köpte ocz vector som windows disk.

triDave
Gäst
2 Årtal 4 dagar sedan

Bra av NHW att gå ut med detta, fastän ni har rekommenderat disken!

Samsung support bland det värsta jag har upplevt, min jävla dator som hade kasst minne(blåscreenade i memtest), samt 7-9 döda pixlar. Fick tillbaka datorn med utbytt hårddisk efter sex veckor. Samt så hade de installerat utorrent med olaglig programvara(partition magic). Samt att de gjort så att datorn inte ens kund köra memtest, dvs datorn dumpade innan man startade memtest. Skickade in den igen fick veta av Inet att skärmen var bytt, men bad inet att köra memtest innan de kunde skicka den till mig. De kunde inte heller starta den. Inet gav mig pengarna tillbaka, så all kudoz till dem, men va faan höll Samsung på med???

Patrik A
Gäst
Patrik A
2 Årtal 2 dagar sedan
PC perspective har jort en youtube video om problemet.Det intressanta med deras ena disk var ju att den fungerade normalt föra året när den togs ur drift varpå den nu efter att ha legat nästan ett år var slö på deras 400Gb+ fil.Samma fenomen har andra användare rapporterat flera veckor tillbaks, en som hade igång sin i 8 timmar på overclock.net och sedan hade den liggandes ett år och felet uppstod därmed när den var strömlös. Så det faktum att PC perspektive råkade ut för samma sak mer eller mindre utesluter firmwaren som riktiga felet utan nåt händer med hådvaran. Det jag trott i 2 veckor nu sedan jag satte mig in i problemet.PC perspektiv kom till samma slutsats. Dessutom styrks det av det faktum att styrkretsen som har flera processorer throttlar ner sig vid höga temperaturer och man kan enkelt trigga throttligen genom att värma upp SSD:n. Då tappar enheten typ halva sin prestanda men enbart på drabbade områden som redan var slöa och inte snabba. Det tyder på att enheten exekverar fler instruktioner för att hämta datan som degraderat så mest troligen kör den kod för en mjukvaruimplementerad ECC funktion eller liknade felkorrigering. Så rätt säker på att… Läs hela »
Bengancom
Gäst
Bengancom
2 Årtal 2 dagar sedan

Jag hade också det här problemet med min 840 EVO men efter körning med DiskFresh så fick disken igen full prestanda i HD Tune.

En annan lite rolig sak som jag märkte nu är att HD Tune inte ger mig full hastighet ifrån disken om jag kör med “Balanserat energischema” i Windows 8.1. Ställer jag om till Hög prestanda så hoppar kurvan upp ca 80 MB/s (men då går så klart cpu konstant på 100%)! Det verkar som att Windows inte drar upp CPU klockan tillräckligt för att HD Tune skall visa max prestanda när man kör Balanserat.

Testade även att slå igång ett program i bakgrunden för att tvinga upp CPU klockan vid Balanserat och direkt så hoppar kurvan upp till samma värde som man får vid Hög Prestanda schemat…

Lite nyfiken på om detta är något som ni testare märkt av? Jag kör för övrigt med IntelRST drivare och Asus Maximus VI Hero moderkort.

T
Gäst
T
1 År 11 månader sedan

Såhär blir man behandlad på CDON: Efter många färggranna, detaljerade epostmeddelanden så vill nu CDON att jag skickar in Samsung 840 för REPARATION. Dom har tydligen nån SSD guru som är en officiell Samsung SSD reparatör 😆 ..snubben sitter där med MyDefrag och Diskfresh redo att imponera stort på sin arbetsgivare, eller så tänker han köra med jackpot-lösningen: Vänta på firmware som KANSKE rättar till saken. Så att på detta viset, dom luras med saker man kan göra själv, men som bonus så får man vänta tills 17 november 2017 när firmware möjligen anländer och sedan ominstallera Windows. Plus att dom har noll garanti på att problemet inte återuppstår. Men nu vet ni allihopa iaf att CDON har den enda officiella Samsung SSD reparationstjänsten i världen. Noll chans att jag skickar nåt åt dom, också noll chans att jag nånsin handlar hos CDON igen. Bevisat defekt vara, med 18 mån kvar av garantin, och dom vägrar ersätta den. Kan väl inte vara lagligt detta..Skitfirma.

T
Gäst
T
1 År 11 månader sedan

Nu har det då alltså kommit en “Samsung SSD 840 EVO Performance Restoration Software” grej..MEN VAR FAN BLEV DEN FÖR 840 Basic då??? Dö Samsung, dö.

André Aronsson
Medlem
1 År 11 månader sedan

[quote name=”T”]Nu har det då alltså kommit en “Samsung SSD 840 EVO Performance Restoration Software” grej..MEN VAR FAN BLEV DEN FÖR 840 Basic då??? Dö Samsung, dö.[/quote]

om du tar några chill-pill och lugnar ner dig så kommer det nog ett verktyg för den också.
samsung har ju inte gått ut med att de inte ska göra något med vanliga 840, eller?

André Aronsson
Medlem
1 År 10 månader sedan

[quote name=”-Tjalve-“][quote name=”pjuppi”][quote name=”T”]Nu har det då alltså kommit en “Samsung SSD 840 EVO Performance Restoration Software” grej..MEN VAR FAN BLEV DEN FÖR 840 Basic då??? Dö Samsung, dö.[/quote]

om du tar några chill-pill och lugnar ner dig så kommer det nog ett verktyg för den också.
samsung har ju inte gått ut med att de inte ska göra något med vanliga 840, eller?[/quote]

Samsung har tyvärr vart mycket tysta angående vanliga 840. Risken är att de bara kommr låtsas som ingeting eftersom 840 ändå snart är EOL. Jag har försökt tryca på de kontakte som jag har hos Samsung, men de vedt tyvärr inte mer än vi. Det är Sydkorea som lagt locket på tydligen…[/quote]

ähm ja, jag börjar bli lite orolig jag me nu 😛 iom som du säger att den är EOL, men de måste ju göra något tycker man ju, oavsett om det är en “budget” modell… och borde ju inte skilja så mycket gentemot EVO? aja… den som lever får se.

Farzan
Gäst
Farzan
1 År 9 månader sedan

[quote name=”-Tjalve-“]Nya uppgifter tyder dock på att det kan vara något på gång för vANLIGA 840.[/quote]

Verkar vara så att vanliga 840 blev utan fix till slut.. 🙁
Aldrig mera Samsung.

EddieEdwards
Gäst
EddieEdwards
1 År 7 månader sedan

Så var då reparationsförsök nummer 2 på väg, kanske. Möjligen. Tragikomiskt dethär. http://www.anandtech.com/show/8997/samsung-releases-statement-on-840-evo-performance-another-fix-is-in-the-works

wpDiscuz