För några månader sedan så kunde vi berätta att Samsungs populära SSD 840 EVO led av prestandaproblem efter långvarig användning. Samsung släppte efter en egen utredning en ny firmwareuppdatering som löste problemet men nu säger nya rapporter att detta bara var tillfälligt.

I vår artikel från förra året så berättade vi om de prestandaproblem som drabbat många ägare av Samsungs populära SSD-enhet 840 Evo. För er som inte känner till felet så handlar det om en bugg i Samsungs firmware. Felet började uppstå i slutet av sommaren 2014 där fler och fler användare kunde visa upp väldigt låga läshastigheter. I vanliga fall så brukar en SSD leverera mellan 350 och 500 megabyte per sekund i sekventiell läsning. Detta är den kanske ”lättaste” formen av belastning. Men det är just sekventiell läshastighet som har varit problematisk för Samsungs budgetmodell.

Det kluriga är att felet inte uppstår direkt utan ser ut att gradvis framträda vartefter filer blir äldre. Så en helt nyinstallerad SSD presterar precis som den ska. Men om man använder enheten som vanligt i några veckor så börjar man se att läsprestandan försämras utan någon som helst anledning.

Är TLC boven?

Samsung påstod sig ha hittat en bugg i sina städrutiner. Tillverkaren menade att det räckte med att uppdatera firmware på sin enhet så skulle problemet lösa sig själv. Man gav även ut en särskild programvara som ”skriver om” datan på enheten så att prestandan återställdes. Vi trodde därmed att problemet var löst, vilket nu visar sig vara felaktigt. Samsung gjorde inte heller någon uppdatering för sin 840-serie som också lider av samma fel. Detta har fått många att tro att detta inte är ett fel som är bara gäller Samsung och deras 840 serie. Kan det till och med vara ett problem i TLC-minnestekniken? Det känns som en logisk slutsats eftersom båda TLC-enheterna 840 och 840 Evo tycks ha problemet. Medan 840 Pro som använder MLC-teknik, lider inte av samma fel.

Vi har givetvis sökt Samsung för en kommentar angående detta och medan vi väntar på Samsungs officiella svar så har vi startat ett litet experiment. Vi tar tre stycken TLC-baserade SSD-enheter (840 Evo, 850 Evo och Sandisk Ultra 2) och sedan installerar vi ett OS på dem och lägger en en massa ströfiler. Vi installerar några stora spel och kopierar in lite musik, bilder och filmer. Efter det så gjorde vi ett lästest på alla 3 enheterna. Resultatet ser ni här nedan.

  
 

Här ser vi vår 840 Evo (högst upp) ger oss finfin prestanda. Även 850 Evo (ner till vänster) och Ultra 2 (nere till höger) visar bra prestanda. Det är lite små dippar på 850 och Ultra2, men dessa beror troligtvis på de kör någon form av garbage collection i bakrunden.

Nu ska dessa tre enheter läggas ner i lådan och sedan ska de ligga där i en vecka. Då tar vi fram dem och bootar upp dem och kör samma test på dem. En vecka senare så gör vi samma sak igen. Detta ska vi göra ända tills vi börjar se att 840 Evo visar prestandaproblem. Principen här är att vartefter datan ligger still i minneskretsarna så kommer datan att degraderas med tiden. Detta är normalt och händer med alla enheter. men för att läsa tillbaka datan korrekt så används ECC (error correcting code) för att rätta eventuella läsfel. Här tror man altså att 840 Evo har ett fel som gör att ECC koden tar upp betydligt mer beräkningskapacitet än vad den borde, vilket resulterar i sämre läsprestanda. Problemet borde altså bli värre ju längre enheten ligger i vila.

Målet är att se om Sandisk Ultra 2 och 850 Evo har samma problem. Vi kommer givetvis att hålla er uppdaterade vartefter vi får in mer information.


Skriv en kommentar

4 Kommentarer på "Läsproblemen med Samsung 840 Evo fortsätter"

Notifiera vid
avatar

Sortera efter:   senaste | äldsta | flest röster
PBengan
Gäst
PBengan
1 År 5 månader sedan

Ja, det här var intressant…

Jag har två 840 evo som uppdaterades i oktober när fixen släpptes.

Första är system/program/spel-disk och den ser nu tre månader senare helt ok ut:

Andra är en tempdisk för nerladdningar, torrents, skratchdisk för ps mm. och där ligger även en del större filer som är över ett år gamla. Den ser lite skum ut men ändå inte alls så illa som innan fixen:

Den disken har det dessutom skrivits till ca dubbelt så mycket som systemdisken.

Båda diskarna har jag lämnat 10% oallokerat utrymme på för over provisioning.

PS. CPU-användningen är hög för jag körde en tråd i prime95 så processorn skulle hålla sig i maxklock under hela testet.

Patrik Alowersson
Gäst
Patrik Alowersson
1 År 5 månader sedan

En annan väntar ju fortfarande på fix för 840 (ej EVO).
Dessutom patchade jag en 840 EVO och gav till polaren. Ska man nu behöva förklara för han att disken han fick kan lida av felet IGEN? Tröt jag blir på Samsung.

Ghost^[Homie]
Medlem
1 År 4 månader sedan

Även jag har 2 st av dessa diskar.
Jag lider inte så mkt av detta problemet då jag installerar om mitt OS var månad
(kör mina i RAID 0 för bästa prestanda).

Men tycker ändå att det är irriterande att höra att fixen som kom inte verkar hjälpa nämnvärt… 🙁

Kommer följa detta med spänning och hoppas samsung gör rätt för sig.

wpDiscuz